rosskalla

K 1 Noisy pot on channel one

Recommended Posts

rosskalla    0

HI all

I'm using a K1 for my bass and I'm very happy with my sound.

I've developed a nasty crunchy, crackling sound when I turn my level control. Is there anything I can do about it?

Regards

Ross

Australia

Share this post


Link to post
Share on other sites
KWhitehead    0

Sometimes rotating the pot back and fourth several times will clean out the contacts. Otherwise you need to open the amplifier up and remove the display board the pots are attached to and use contact cleaner sprayed inside the pot. If this needs to be done I would contact your distributor which is Jands to have them perform the cleaning.

Thanks,

Kip Whitehead

Crown Technical Support

Share this post


Link to post
Share on other sites
rosskalla    0
Sometimes rotating the pot back and fourth several times will clean out the contacts. Otherwise you need to open the amplifier up and remove the display board the pots are attached to and use contact cleaner sprayed inside the pot. If this needs to be done I would contact your distributor which is Jands to have them perform the cleaning.

Thanks,

Kip Whitehead

Crown Technical Support

1807[/snapback]

Thanks Kip, much appreciated. Jands is about 600 miles from here, so I'll have a cautious look meself.

Kind regards

Ross

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now