Problem updating firmware itech 12000

Recommended Posts

jca380    0

I did tried to update my it12000hd firmware that is actually to the newest via system architect 3.4 and ethernet and it says they cant complete the update in the error log. I did tried via usb buy putting the file (if i remember well) ithd1122.bnd on a usb key. It was the only file on the usb key and when i plug it in the front panel of the itech the amp dosent find any file on the usb key. Anyone could help with this update please?


Share this post

Link to post
Share on other sites
joust    0

Is it possible that SA sees you as an ordinary 'user'? You may need administrator's rights (privileges) to update the amp.

Click right on the SA shortcut, and you should see the 'Run as...' entry. Select it and enter the PC's administrator password.

I have also seen the Window's Firewall may halt any task you may ask SA to do. You may have to add SA to the exception list.


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now