CurtZHP

D-75 Calibration questions

Recommended Posts

CurtZHP    0

I've got an older model D-75 that has served me well. I've already replaced the 820Ohm resistors with 910's, so that's taken care of. The new problem I've discovered is that the right channel does not put out as much level as the left when the level controls are set the same.

Is there a way to calibrate this unit to get them to match, or am I looking at a larger problem?

I checked the service manual and didn't see anything about it.

Share this post


Link to post
Share on other sites
I've got an older model D-75 that has served me well. I've already replaced the 820Ohm resistors with 910's, so that's taken care of. The new problem I've discovered is that the right channel does not put out as much level as the left when the level controls are set the same.

Is there a way to calibrate this unit to get them to match, or am I looking at a larger problem?

I checked the service manual and didn't see anything about it.

Each channel has a CMR pot on the input side. I have seen cases of the pot becoming dirty and can cause level differecnes per channel. You could also swap the front pot connections from channel to channel to see if the level difference follows. You may have a bad or dirty pot.

Thanks

Kip Whitehead

Crown FSE

Share this post


Link to post
Share on other sites
CurtZHP    0

I'm assuming the CMR pot is the one located on the non-inverting input to U2 on the schematic. (CMR=Common Mode Rejection?)

And just to verify, R101 and R201 refer to the front panel level controls?

Also, once I clean the CMR pots, how do I verify their correct settings?

Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now