Recommended Posts

I am using a crown micro tech 600 amplifier to power to JBL 3677 speakers in my home theater system. Majority of the time when i turn off my amp, there is a popping sound that goes through the speakers and im afraid it will damage the HF driver. I have tried shutting the amp off first, then the reciever and vice versa, but i still have the problem.

any advice appreciated

Jon

Share this post


Link to post
Share on other sites
SteveO    0
I am using a crown micro tech 600 amplifier to power to JBL 3677 speakers in my home theater system.  Majority of the time when i turn off my amp, there is a popping sound that goes through the speakers and im afraid it will damage the HF driver.  I have tried shutting the amp off first, then the reciever and vice versa, but i still have the problem.

any advice appreciated

Jon

986[/snapback]

Try turning the gain pots on the amp all the way down before turning it off.

Share this post


Link to post
Share on other sites
DGlass    0
I am using a crown micro tech 600 amplifier to power to JBL 3677 speakers in my home theater system.  Majority of the time when i turn off my amp, there is a popping sound that goes through the speakers and im afraid it will damage the HF driver.  I have tried shutting the amp off first, then the reciever and vice versa, but i still have the problem.

any advice appreciated

Jon

986[/snapback]

The issue probably resides in that the +/-15 volt low voltage supply is discharging unevenly. This could be because of many reasons such as capacitance changing, the load on the regulators has changed over time, or even the regulators themselves.

The first place to check would be the +/-15 volt low voltage supply capacitors C1 and C2. C1 by the book should be 1000uf and C2 should be 470uf. Try replacing C1 with a 470uf cap. If they are both already matched at 470uf replace C1 with a 1000uf cap.

Next I would look at the +/- 15-volt supplies with an Oscilloscope to see what side of the supply is leading the other in discharging. This leading side will need to be slowed down. To do this you may have to change U1 and or U2.

If that doesn't work you may have to add capacitance to the leading side starting with a 2.2uf electrolytic. This would be added on the regulated (output) side of the = or - supply.

If needed schematics and a service manual are available on our web site at: http://www.crownaudio.com/gen_htm/legacy/legacamp.htm

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now