Sign in to follow this  

XTI USB Drivers - device cannot be discovered

Recommended Posts


this is the first time i have tried to use the Band Manager / Sys Architect with this XTI 4000 amp, and it is causing me major problems - so i was wondering if you guys have some help for me?

The XTI amp is being recognised as a Realtec Card in my Device Manager, and each time i try and install the amp it's getting stuck in the Mouse+Keyboard section and as such is not being recognised by the Band Manager / Sys Architect Software.

I have a fair amount of IT experience so i have tried deleting it and re-installing it, i have tried searching for software updating the drivers and i am finding nothing - stuck in a loop.

Could someone please point me in the direction of the USB Driver file for XTI Amps and i will be able to specify the file while installing it again.

Thanks in advance for all of your assistance


Share this post

Link to post
Share on other sites

And before anyone asks - "Yes" my serial number for the Amp is above the stated 800129400 so i should not have to update the firmware for the Sys Architect to communicate. Also as a note there is XP with SP2 on the machine and it meets all requirements for spec (.net 3.5 / Ram etc)

I have just seen that there is a potential USB Driver in the folder that is downloaded for the 'Firmware Upgrade' so i will see if i can download this and then specify the file when installing the device again.


Share this post

Link to post
Share on other sites

1 - I tried to use the Firmware upgrade file to see if i could get to the XTI usb driver, but the .s file extension can only be read by the cloader program (Failed)

2 - I used the Cloader program and ran a full Firmware upgrade, the amp did everything it was supposed to and the connection between PC and amp was perfection in digital communication (success)

3 - Closed Cloader when the amp had rebooted and 'DSP OFF' showing on the LCD front panel, as instructed (success)

4 - Opened Band Manager, no devices found (Failed again)

5 - Uninstalled and re-installed Band Manager, no devices found (Failed again)

6 - Re-installed Sys Architect, no devices found (Failed again)

Failed Again!!!

So to sum up things up:

I have spent hours of my life trying to use this software on my PC. One piece of the Harmon Software is able to recognize the Amp instantly (Cloader Firmware upgrade), where all of the other pieces of Harmon Software do not. The PC had a fresh install of XP last week after reformatting, and has been updated completely with all the official licensed Microsoft products. I do not use a USB hub, there are only 2 other USB ports being used (mouse and Keyboard), all specifications for loading the Harmon Software have been met or exceeded. At the moment i am even contemplating installing Parallels and then XP on to my Macbook in an attempt to get this going.

My final point on this matter:

For the love of God will someone please tell me where i can find the correct USB driver for an XTI amp so my PC will communicate with it

Thank you

Share this post

Link to post
Share on other sites
Kevin Heber    0

My apologies for the delayed reply. Can you please verify your XTi firmware version by doing the following:

-- Hold down all 3 front panel buttons for about 1 second

-- Press NEXT several times until you see the firmware version # -- something like

Also, in System Architect, go to tools/options/connectivity settings/manage connections and check to make sure that the list box "USB Devices" is populated with something.

Please let me know what you find.

Share this post

Link to post
Share on other sites

Hi Kevin,

thanks for getting back to me.

My Firmware number is now showing as exactly # after going through the upgrade at the weekend.

I have brought home a works XP laptop to see if this will be more accomodating with the Amp.

I will let you know the result.



The Laptop died a death, black screens etc - so what is your next idea?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this