Some minor problems - I AM controlling multiple DSI's over USB

Recommended Posts

sknapp1    0


We've been waiting to test out multiple DSI's (CDI, XTI...) via an USB hub. Today I finally had the chance, though it was a few hours in the shop, but I think this will be greatly beneficial out in the field for our engineers.

Here's what I did, and the few problems I ran into:

Stuff on hand: 8 DSI's, all with old firmware. Three 4-port USB 2.0 hubs, non powered. Intellix's USB over ethernet bauln. 100' Cat5e

First off, I had to update each DSI with the new firmware, one at a time or Windows will blue screen. Time consuming.

Second, I connected all updated DSI's to the hubs all linked together and connected to SA. (First problem here) SA ran into multiple addressing problems where alot of the time it tried to call multiple amps by the same name 'Amp 1', which lead to communication problems. I tried to auto address randomly, but because of communication problems it would hang up 'waiting on response'.

So I, thirdly, went back to connecting to each amp one by one. Giving each a manual address number at this point. (Second problem here) Though sometimes those that all were still trying to be named 'Amp 1' would not recognize completely. I found powering off/on the amp fixes that. Sometimes coupling with restarting SA also helped. This one was hard to troubleshoot.

Fourthly, with each of the eight amps having a different address, I reconnected to the daisy chain of hubs, hooked to my USB port and viola - They all appeared and no blue screen.

Now, Fifthly, when I connect at the rack straight to my computer I can see each of the eight amplifiers as online. (Third problem here) But when I connect to the Intelix extender, only seven show online and an message balloon appears saying I have exceeded the maximum bandwidth for my USB host controller. The Intelix extender works wonderfully, no lost connection, but apparently seven units are all it can handle.

So, any ideas from anyone on the addressing issues, where I had to spend quite a while doing it manually. Or any ideas on increasing bandwidth to a USB host controller in Windows?


Share this post

Link to post
Share on other sites
DGlass    0

The Blue Screen issue was a Microsoft USB OS issue that we found a way around and was addressed in System Architect 1.30 and firmware and has been discussed extensively in other postings.

To address the Blue Screen issue all amps would have to updated to at least firmware.

In the addressing instructions it explains that each amp will need an independent device addresse and will need to be done one at a time. This is due to certain limitations of USB.

I am not exactly sure which Intelix device you are using but I am guessing it is the "Digi-USB-F" as it was the only USB extention devive on there web site I could find. We have never tested any of the Intelix devises so I cannot directly address any issues you are having with it. However it is a "Balum" which tells me it is not converting USB to Ethernet but it is just sticking the USB signal onto CAT cable.

I have only tested the AnywhereUSB device by InsideOut Networks/DIGI International as a USB extention device and it does it over Ethernet and I fould it to work. (AnywhereUSB). Even at that I send the following note to anyone looking at using it or any similar device.

Although we don’t “officially” recommend a Ethernet to USB device I have done some testing on the Inside Out Networks/Digi Connectware “Anywhere USB” Device. They have a great reputation and have an excellent Tech Support staff that is very assistive. Once the drivers have been installed and the unit is addressed its operation is transparent and it has been working very well with a very solid connection. The unit has 5-ports per device and becomes the IP address for the USB devices to have access to an Ethernet network. Currently this is the only device I have working although there may be others that may work just as well.

This testing has been on my own and outside the official Crown work. The device shipped with old drivers and once I downloaded the latest drivers (v1.8) it has been working solidly. The unit was priced just under $300.00 USD. The Techs at Digi told me they also make this for several other companies so you may find the same device with a different name.

There are a few things when using a USB to Ethernet device of this type to keep in mind:

First: All XTi/CDi/Dsi amplifiers should be HIQnet addressed (one at a time) by direct computer connection before attaching them to the USB-Ethernet extension device.

Second because of timing issues between converting back and forth from USB and Ethernet Do Not try to update firmware through the Ethernet Converter to the amplifiers. This should only be done with a direct connection or through a USB hub connected to the computer.

Thirdly any USB Hubs that may be attached to add more devices should be self powered not Bus powered. This not only applies to using a Hub with the USB to Ethernet converter but in general as well.

Fourthly remember these are serial communication devices so even though the meters and such look real time you are really only seeing one device at a time and they are time sharing the Ethernet connection.

Finally You need to use the latest firmware or multiple amps will crash the computer due to a Microsoft USB issue.

Other than this I have tested up to ten XTi amps in various configurations with a USB hub added on. Everything I have tested has worked very well.

Note: Now for the obligatory disclaimer. Crown nor myself make any guarantees as to the performance of your individual system.

Share this post

Link to post
Share on other sites
sknapp1    0


Thanks for the reply.

Yes, it is the Intelix Digi-USB unit that I'm using. It's on demo from them, so I can test it in this application for our field engineers.

When talking to Intelix's techs they thought I might be having issues do to voltage loss, meaning the DSIs needed a powered hub (much like your posting recommended). However, I found no change when applying power to my hubs to when I was using them unpowered. It still only recognized 7 over the Intelix unit and 8 locally.

- Note: I am using three 4-port hubs linked together to give me enough ports to have all 8 DSIs online at once.

So far though. My limitation has been 7 amps at once over the Intelix unit because Windows says it has exceeded the maximum bandwidth. In system properties the Host Controller for that USB is at 94%, so possibly that is why it will not initialize the 8th amp ("failed to start" error in system properties).

However. 7 is still stellar. And with the price tag on the Intelix unit at $190 MSRP, it looks like a great tool for our field engineers.

The only issue I've ran into now is, once on two different laptops I was testing with, they have lost network connections while being connected to the amps. I don't know if this is related to SA or Intelix or neither. Both had to reenable the adaptors to get ethernet again. I'm trying to dive more into that one.

Thanks again.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now