avdavesound

crown xti amp service

Recommended Posts

avdavesound    0

hi i recently purchased 6 crown xti amps from the usa i'm based in Ireland, the amps work fine but i'm hearing so much about dodgy xti amps. where would i have to sent them if one of them acts up? as shipping to to the usa is exspensive? if i do do crown refund shipping? also i'm a trade buyer i get trade discount here in Ireland why are they so cheap in america which are end user prices and the trade price i'm getting is not far from twice the price of the american end user price? and no my supplier is not ripping me off there that price everywhere in europe.

sorry!!!

ps i've never had a problem with crown amps i've 2 microtech amps in a install on a ship installed 15 years ago never serviced or turned off and the only thing wrong is a squeaky fan! now that quality! keep up the good work hope the xti's last that long.

thanks

Share this post


Link to post
Share on other sites
Stephane    0

Just do a search here but from what i did read you gonna have to ship it back in USA at your own expense :( , i was about to buy mine from the us as well because there is about 150$ make up here in Canada as well :( even after shipping and duty and i end up buying mine in Canada anyway just because of that shipping would be about 75-80 one way plus the assle to ship it good luck.

hi i recently purchased 6 crown xti amps from the usa i'm based in Ireland, the amps work fine but i'm hearing so much about dodgy xti amps. where would i have to sent them if one of them acts up? as shipping to to the usa is exspensive? if i do do crown refund shipping? also i'm a trade buyer i get trade discount here in Ireland why are they so cheap in america which are end user prices and the trade price i'm getting is not far from twice the price of the american end user price? and no my supplier is not ripping me off there that price everywhere in europe.

sorry!!!

ps i've never had a problem with crown amps i've 2 microtech amps in a install on a ship installed 15 years ago never serviced or turned off and the only thing wrong is a squeaky fan! now that quality! keep up the good work hope the xti's last that long.

thanks

5435[/snapback]

Share this post


Link to post
Share on other sites
DGlass    0

Since the amps were purchased in the US they would need to come back to the US for Warranty Service should they ever break. Do to International Trade agreements, laws and Independent countries restrictions International Distributors are not required to perform warranty service on equipment they did not import. It's not just you the same thing happens in the US when people purchase equipment overseas and bring them back to the US. Should they brake the customer will find that the US Distributor does not have to service the equipment if they elect not to.

Share this post


Link to post
Share on other sites
lamdig    0

I am having troubles with my XTi6000 - at first it was shutting down for 30-50 seconds or so (guesstimated) when driven hard. The last gig was throughout the whole night, even with the system not being pushed hard. I put a fan in front of the amp and it somewhat helped but we backed off on the system considerably and so I had some unhappy customers.

I am running it in stereo and driving a pair of Yorkville U215s (approx. 1800 watts apiece). DSP is set to cut these off at 90 Hz and 18 KHz and the amp is limited by -3db given its output at 4 ohms stereo.

There is about 2 months remaining on the 3 year warranty so i am gettiing nervous and have asked the USA vendor who sold them to me to advise. Thoughts anyone?

I am in Nova Scotia by the way

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now