Sign in to follow this  
dolores

buzz on crown dc300a

Recommended Posts

dolores    0

just got a crown dc300a, hooked it up and got some serious buzz coming out of my speakers (urei 813b). as soon as i hit the powerswitch it starts, volume level on the amp doesn't change the level of the buzz, neither does unplugging the input signal.

any ideas what that could be?

thanks

Share this post


Link to post
Share on other sites
mtarr    0
just got a crown dc300a, hooked it up and got some serious buzz coming out of my speakers (urei 813b). as soon as i hit the powerswitch it starts, volume level on the amp doesn't change the level of the buzz, neither does unplugging the input signal.

any ideas what that could be?

thanks

3649[/snapback]

Dolores,

I just fixed my amp, same symptoms. I changed C4 and C5.

-Morty

Share this post


Link to post
Share on other sites
dolores    0
just got a crown dc300a, hooked it up and got some serious buzz coming out of my speakers (urei 813b). as soon as i hit the powerswitch it starts, volume level on the amp doesn't change the level of the buzz, neither does unplugging the input signal.

any ideas what that could be?

thanks

3649[/snapback]

Dolores,

I just fixed my amp, same symptoms. I changed C4 and C5.

-Morty

3723[/snapback]

this is a little beyond my comprehension. what is c4 and c5?

thanks

Share this post


Link to post
Share on other sites
Stephane    0

Capacitor number 4 and 5(C4,C5) if you look on your electronic schematic of your amplifier,C4 is a 10 mfd 160 volts and C5 is a 10 mfd 50 volts vertical. Good luck.

just got a crown dc300a, hooked it up and got some serious buzz coming out of my speakers (urei 813b). as soon as i hit the powerswitch it starts, volume level on the amp doesn't change the level of the buzz, neither does unplugging the input signal.

any ideas what that could be?

thanks

3649[/snapback]

Dolores,

I just fixed my amp, same symptoms. I changed C4 and C5.

-Morty

3723[/snapback]

this is a little beyond my comprehension. what is c4 and c5?

thanks

3782[/snapback]

Share this post


Link to post
Share on other sites
joust    0

I don't know if this will help, but I had this DC300 with low volume buzz that I couldn't remove. A local tech advised me to replace the micas isolators on the output devices. Lo and behold! the buzz disappeared! :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this