piruloy2k

Members
  • Content count

    8
  • Joined

  • Last visited

Community Reputation

0 Neutral

About piruloy2k

  1. Trying to get the best setting for running this. How can XOVER setting can help me? I was thinking running XOVER mode, with SUB on channel 1, and the PR12 on channel 2, daisychain. Is this OK? How much power I will obtain with this? and how I can maximize? XTI 2000 (1) Peaver PR12 (2) Black Widow SUB 18" (1)
  2. Yes you can,think the amp as 2 mono amps in one case, as long you load within minimum spec the amplifier does not care, cheer Thanks for the suggestion!
  3. XTI2000 in Bridge or Stereo

    Ok thanks for the suggestions!
  4. Hi Team; Actually I'm running my two (2) XTI2000 amps with this config: one xti2000 in Stereo Mode with two (2) 8-omh speakers on each Channel, on pararell (4omh both channels) one xti2000 in Bridge Mode with two (2) 8-omh subs connected in parallel to channel one (4 omh load) Surely on my Subs amplifier I think I have the best setup . If not, let me know. In case of the other amp, is this setup OK, or how I can get the most of this Amp? Can I run in on Bridge mode and connect all four speakers in parallel to a 2omh load? Can this improve my sound power? Thanks; Carlos Brea Puerto Rico
  5. Hi Team; Can I run one XTI2000 with different load on channels in Stereo Mode? I'm planning to hook up 4 four 8-omh speakers in channel 1 and 2 two 8-omh subs on the other, obviously all of them in parallel in their own channel. If this possible or will kill the amp because Channel 1 will be in 2omh and Channel B in 4omh? What will be the recommended setting in this scenario? Thanks! Carlos Brea Puerto Rico
  6. Hi Team; I have an xti 2000 running four speakers : two JBLJR115 and two Peavey PR-12, chained ( run at 4omh) Rigth know i just set the amp to Stereo, and connect one Peavey to channel A and connect one JBL to that cabinet. Same as the other channel B. This will the setup for mi mids and higs.....I have other XTI2000 for my SUBS. ;-) System works OK, but I want to get out the most from my system. Im a newby on this, close to one year, and theres a lot of settings to change at the software ( crossover, eqs, filters, delay, etc etc) Is theres a recommended setting to get the most out of this configuration??? Thanks! Carlos Puerto Rico
  7. Hi Team; I have an xti 2000 running two Peavey 18" Black Widow chained ( run at 4omh) Rigth know i just set the amp to Bridge Sub, and connect one sub to channel A and connect the other to the sub. System works ok, but I want to get out the most from my system. Im a newby on this, close to one year, and theres a lot of settings to change at the software ( corssover, eqs, etc etc) Is theres a recommended setting to get the most out of this subs? Thanks! Carlos Puerto Rico
  8. Hi Team; I have a XTI 2000 no power on, completely dead. Is under warranty but I have a lot of parties to do on this holidays. I already disconnect all speaker cables, and also the power cord and try, but no luck. I have another XTi2000 unit and works OK. Both of them have only 15 months with me. Is there is a way I can verify any fuse prior to send it to repair.?? I cant find any outside fuse on it, and I dont want to open the case to avoid loose warranty. What are my options? Carlos Brea Puerto Rico