Jump to content


mikehende

Member Since 12 Nov 2013
Offline Last Active Jan 17 2014 02:32 PM
-----

Posts I've Made

In Topic: Is it safe to run this amp with this speaker setup?

16 January 2014 - 10:47 AM

well, that's a lot of technical knowledge, really appreciate you taking the time to explain all of this and I thank both you and Stephane for your help and advice!

In Topic: Is it safe to run this amp with this speaker setup?

16 January 2014 - 09:31 AM

View Postjoust, on 16 January 2014 - 09:07 AM, said:

Note 2 : For better thermal management, especially at high levels, refurbish the output stages at a regular intervals. It will make the amp run better!
Alain

Thanks, can you explain the above please as I am not understanding what you mean by "refurbish the output stages at a regular intervals"?

In Topic: Is it safe to run this amp with this speaker setup?

16 January 2014 - 07:46 AM

Thanks for the advice on the speakers, I am not concerned about them really as I use a general rule when playing music, if I hear any distortion or see the clipping lights going off I cut back on the volume, my main concern with this is running the amp with "mis-matched" ohms per channel, since you've confirmed that with my current speaker usage, both channels on the amp amps are running in 4 ohms mode [thanks again] then this is safe for the amp so far so good. Let me throw one more issue at you if you won't mind please? I am thinking of adding one single 15" sub to the sonic meaning I plug the 15" sub directly into the Sonic's connector so would this mean that amp channel which runs the sonic will be now running at 2ohms? If yes, then would it be ok [for the amp] to run speakers in mis-matched mode so as in this case 4 ohms on one side for the Peavey tops and 2 ohms on the other channel for the sonci and the 15" subs?

In Topic: Is it safe to run this amp with this speaker setup?

15 January 2014 - 09:58 AM

Safe for the amp? This is the Sonic Speaker:

www.sonicspeaker.com/r218sub.htm

and these are the biampable tops like what I have, as mentioned they are run full range with one speaker connected to the other then that goes back to the amp so I am guessing this is 4 ohms mode? If so, is the Sonic sub running at 8 or 4 ohms please?

http://www.ebay.com/...=p2047675.l2557