Jump to content


Fspatola

Member Since 24 Oct 2013
Offline Last Active Dec 12 2014 08:58 PM
-----

Topics I've Started

K2 Goes in and out of sleep mode every couple of seconds.

17 October 2014 - 07:27 AM

Hi all, I have a K2 on the bench that in going in and out of sleep mode. The power light goes dim and then bright every 2 seconds with signal applied. On one channel I here sound every 2 seconds on the other I here nothing. So far I replaced C6 100uf 25V, C9 100uf 25V, C23 330uf 16V , & C24 330uf 16V as suggested by Joust on some of his posts. Is anyone familiar this issue.
Thank You, Frank

XLS5000 Service Manual

04 August 2014 - 07:20 PM

Hi all, does anyone have a service manual or schematic for xls5000 that you can send me.
Thank You, Frank

CTS1200 Problem

28 July 2014 - 07:27 AM

Can some please help, I am working on a CTS1200 that had 2 shorted outputs. I replaced all 3 on the same heat sink as well as .68 ohm resistors associated with those drivers. I do not have any more shorts In that channel now. My problem is when I measure the resistance across the base & emitter of the output drivers I get about 34 ohms on all except the 2 that were shorted it is a lot higher. Any ideas on what I should look for. Please help.
Thank You, Frank..

CTS4200a dead

15 March 2014 - 09:16 PM

Hi all, I am working on a CTS4200a that will not power on. I found C13, C15 & C16 buldging on the LV module. I am going to do a recap on the whole LV module. I was wondering if there is anything eles I should check before trying to power it up. I have checked the diodes and transistors. This is my first time working on a CTS amp. Any help would be appreciated.
Thank You, Frank.