Jump to content


XLS602 ventilation problems


  • Please log in to reply
3 replies to this topic

#1 marsonpee

marsonpee
  • Members
  • 2 posts

Posted 24 March 2006 - 11:07 AM

Hello, I have an XLS602 amp and it is a fantastic amp except the fact that it draws in sooooo much dust, has anyone got any suggestions for this or is it just a fact that i will have to clean the insides a lot. Any help will be great.

#2 tcw3200

tcw3200
  • Members
  • 1 posts

Posted 25 March 2006 - 01:42 PM

QUOTE(marsonpee @ Mar 24 2006, 12:07 PM)
Hello, I have an XLS602 amp and it is a fantastic amp except the fact that it draws in sooooo much dust, has anyone got any suggestions for this or is it just a fact that i will have to clean the insides a lot. Any help will be great.
View Post


no help for you, I have the same problem with my XLS602a.  I noticed on my CE 2000s and 4000, the fans kick on when needed rather than running continually.  The only reason I can come up with as to why there is so much dust on and in the XLS is that it is a 2 space amp and the fans run all the time.

#3 marsonpee

marsonpee
  • Members
  • 2 posts

Posted 25 March 2006 - 06:12 PM

How long do you usually get before having to blast it out?

#4 Bud Bolf

Bud Bolf

    Power User

  • Members
  • PipPipPipPipPip
  • 201 posts

Posted 25 March 2006 - 07:47 PM

Howdy,
I have the CE2000 and CE4000 and I just purchased a XS900 that has 2 fans that run all the time.
I have not had a big dust problem as you all have and I keep my Amp rack closed when not using the Amps.

I would wonder if possibly taping a piece of scotch brite pad on the front would help.
The fibers are loose enough that it should catch dust and yet not hinder
the air flow that much.
Maybe David will give his recomendations.
Later,
    Bud