Jump to content


CE2000 cutting out


  • Please log in to reply
1 reply to this topic

#1 djrufhouse

djrufhouse
  • Members
  • 1 posts

Posted 05 August 2005 - 07:36 PM

Hello everyone.  I have been a PROUD Crown user for years.  I have a CE2000 that recently cut out on me when I opened my rack drawer.  When I closed the drawer it came back on.  It happened toward the end of a gig.  I brought it home afterwards to see if I could repeat the problem.  I could.  I moved the amp up away from the drawer thinking maybe I was getting some kind of weird interferen ce from something.  When I powered up again it worked.  I left it on for about twenty minutes and then went to turn down the gains and it went out again.  I lightly tapped the grill ... not knobs... grill and it came back on.  I tapped it again and it went off... tapped it again and it was back on.  Obviously there is something wrong.  I have written to the tech guys here at Crown but does anyone have any ideas?  

Edited:  After reading further posts, this sounds cery similiar to a Cold solder problem experienced by another user of a CE4000.  Any ideas?

#2 DGlass

DGlass

    .

  • Members
  • PipPipPipPipPip
  • 2,541 posts

Posted 08 August 2005 - 09:23 AM

There could be several things causing this including something as simple as a loose AC wire or a bad AC switch. From what I can see of your profile you are from KC-Kansas. We donít have any Authorized service centers in Kansas but we do have one on Leeís Summit, just south of KC-Missouri. Their contact info is below.

Preston Electronics
Ph: 816-537-7242
Fx: 816-537-7325
www.prestcomusic.com

If you wish to send it in to us for repair you can go online to http://www.crownaudio.com/support/factserv.htm and create a Service Return Authorization (SRA)