Jump to content


xti 2002 with sp118s

sp118

  • Please log in to reply
1 reply to this topic

#1 luisunitedking

luisunitedking
  • Members
  • 1 posts

Posted 03 February 2014 - 08:40 PM

hello I have an xti 2002 running with 2 sp118s im wondering what s the best way to set up the amp as o right now I have them set up on the SUBSYNTH application but still they don't sound as much as I wanted them too compared to when I only had 1 sp118 on BRIDGE MONO it sounded way better but if I plug both of the subs on bridge mode they would go from 8 ohms to 4 ohms  ...... now going back to the SUBSYNTH application I hear a lot of slopping sound when I turned them up so my question is

what else can I do to make them sound better ? do I need to set the limier ? should I mess with the crossover ?


please I need help

#2 dakos

dakos

    Admin

  • Members
  • PipPipPipPipPip
  • 766 posts

Posted 09 February 2014 - 01:33 AM

Hello, sorry for the late reply, i've been away for a week long family vacation so...

Since everything was working properly before you connected the second sub, I need to ask you a few questions:
1) Did you absolutely double check the polarity of the cable? If one sub is in reversed polarity, that would kill the bass.
2) How did you position the speakers in the room? It would be most helpful if you can upload a picture of the room you have everything set up.

Now, you must remember that connecting the amp in bridge mono to a 4 ohm load is very unrecommended, it puts a lot of strain on the amp and will probably thermal protect itself, especially using SUBSYNTH. To try and avoid that you should consider getting a bigger amp or a second one.

About using the crossover, you should definitely use it, you will protect your speakers from physical damage to the cone by filtering out the non sonic frequencies plus making the amps life a little easier, especially while using the subsynth function (sounds like an all gain situation here). set up a 3rd or 4th order (18-24dB/Octave) Butterworth HPF at the -3dB of your speaker (48Hz) and you're good to go.

It would also make sense to use the XTIs limiters, you should use long attack and release times, 4 second attack and 6 second release is a good starting point. You should set it up at -8.24dBfs.

Hope this helps
Avi