Jump to content


XLS1000 Fault


  • Please log in to reply
5 replies to this topic

#1 eugeniomx

eugeniomx
  • Members
  • 1 posts

Posted 23 January 2014 - 05:52 PM

I have a XLS 1000, one day it simple stop working and say fault 04/99
Maybe you can help wath does this fault say.
Thanks

Best Regard

#2 joust

joust

    Power User

  • Members
  • PipPipPipPipPip
  • 515 posts

Posted 30 January 2014 - 08:57 AM

Hello Eugenio,

The word is :
'Replace D1 and C5 in the power supply circuit.'
Let me know if it solves your problem!

A.

#3 julius

julius
  • Members
  • 5 posts

Posted 14 November 2014 - 02:37 AM

Hello,

We also have the same issue with our XLS2500 but the error code shown is 04/77. It will stay on for 5 minutes and then the fault shows up..

It only happened last week and we had the amp for more than 3 years now..

I hope you can help.

Thanks!
Julius

#4 joust

joust

    Power User

  • Members
  • PipPipPipPipPip
  • 515 posts

Posted 14 November 2014 - 09:30 AM

Julius, 04/77 is an APM issue. This is part the display module.
I suspect that you may have to replace the display board.
I don't know about you but I find today that there is now less and less user serviceable parts!
Get in touch your your favorite local Crown authorized center.

Alain

#5 julius

julius
  • Members
  • 5 posts

Posted 14 November 2014 - 10:39 AM

Hi Alain,

Thanks, we'll try to bring this to our local dealer here in the Philippines and see if they can repair. However, can this display module
be bought online directly from Crown?

Thanks,
Julius

#6 joust

joust

    Power User

  • Members
  • PipPipPipPipPip
  • 515 posts

Posted 17 November 2014 - 03:48 PM

I don't know! On the Crown site, I see no feature to buy parts online. :( The only suggestion I can offer is to try with your local authorized Crown service center/distributor.
I had a display fault that I found to be a bad 3.3V regulator (LD1117 33V) on the display board.

Alain