Jump to content


D150A II problems


  • Please log in to reply
6 replies to this topic

#1 CarolinaCrown

CarolinaCrown
  • Members
  • 4 posts

Posted 12 May 2012 - 12:24 PM

Hey folks, I'm new to this forum and I'm having a little problem with a D150A II. Both 15003's are blown plus several resistors and a power transistor. I have all the schematics plus the service manual. My main problem is cross referencing the transistors. Mainly its Q107 , p# C 4061-5, its a D40V2 tranny.  I've already replaced several caps, diodes, and the zener diodes. I know I can order parts through Crown but I'd rather get parts on my own. All help is greatly appreciated,Greg

#2 CarolinaCrown

CarolinaCrown
  • Members
  • 4 posts

Posted 17 May 2012 - 07:32 PM

Come on folks. No one has a possible cross reference tranny list? I've search the net with limited luck. I'm guessing no knows about these dinosaurs but it was worth a shot . Maybe another electronics forum would be better.


#3 joust

joust

    Power User

  • Members
  • PipPipPipPipPip
  • 383 posts

Posted 28 May 2012 - 02:42 PM

Hey CC, The C 4061-5 is still available from Crown. It may also be available under C 5065-5. Good luck!

#4 CarolinaCrown

CarolinaCrown
  • Members
  • 4 posts

Posted 29 May 2012 - 05:43 PM

Thanks joust for the info. What I'd really like to know is there a substitute or equivalent from a different manufacturer?

#5 joust

joust

    Power User

  • Members
  • PipPipPipPipPip
  • 383 posts

Posted 05 June 2012 - 01:20 PM

Try National Semi, NSD-128. I'm not sure if this part is still available. That's the only info I have on this substitute.
It appears that the C4061 is also subbed as C5065-5. This one is subbed from GE, D40P3. I don't have info on this one.
Though, try to get the original Crown p/n! It may still be available.

#6 CarolinaCrown

CarolinaCrown
  • Members
  • 4 posts

Posted 05 June 2012 - 04:34 PM

Thanks joust! I think I'll have to bite the bullet and order 'em from crown. But at least I'll know they're the right part. Right??
Thanks again for your input,Greg

#7 karlos the dc300a

karlos the dc300a

    Power User

  • Members
  • PipPipPipPipPip
  • 93 posts

Posted 05 July 2012 - 01:09 PM

go with d40v2 if you can. (dont use anything like d40c1 or similar it has a lower voltage rating and is useless)