Jump to content


CTs2000


  • Please log in to reply
3 replies to this topic

#1 Bcrittenden

Bcrittenden
  • Members
  • 7 posts

Posted 11 May 2012 - 12:27 PM

I have a CTs2000 that will not power on. The power and clip lights flash but doesn't power up. Has anyone else experienced this? Does anyone know where to find the service manual?

Thanks,
Brandon

#2 joust

joust

    Power User

  • Members
  • PipPipPipPipPip
  • 515 posts

Posted 15 May 2012 - 01:07 PM

Brandon, You may have had a major output fault, possibly one or more shorted output devices. Recommend that you bring it to an authorized Crown service center.

#3 Bcrittenden

Bcrittenden
  • Members
  • 7 posts

Posted 23 May 2012 - 01:01 PM

Got an update on the amp. R905, R906, R907, R908 are not testing properly and have a browning around the pcb.

Does anyone think there is a problem upstream (possibly with the transformer?) or if it is limited to the resisters?

Any ideas or information would be MUCH appreciated!

Thanks,
Brandon J Crittenden

#4 joust

joust

    Power User

  • Members
  • PipPipPipPipPip
  • 515 posts

Posted 28 May 2012 - 02:33 PM

Brandon, Did you get to check the output fets? The resistors (R905-8) are bleeding resistors for the BULK filter caps. I don't think they are bad.
With power off and main rail voltages bleeded, remove the rail connector (6 colored wire cable) from the psu to main board. With the connector removed, power up: either the unit stays in protect or the green Ready lights are now lit. If it stays in Protect, the SMPS may be bad; If the Ready lights appear, there is a possible fault in the output section.