Jump to content


CROWN XLS 802 SIGNAL L.E.D.'S


  • Please log in to reply
2 replies to this topic

#1 knotter77

knotter77
  • Members
  • 4 posts

Posted 07 November 2011 - 04:06 PM

i have a question in regards to possibly buying a amp its a XLS802, the GREEN LEDS stay lit at power up regardless if there is xlr input is connected or not.. is this normal operation?

* i turned power on: blue power light lit -normal - not an issue

looks like the yellow protection light comes on for a couple of seconds that turns off , but the green leds just stay lit WITH no cables connected .. normal or what you all think??

*so yeah its plugged into the wall pushed the power button with no cables or anything else and green led lights and blue power button are all on.... are the green leds supposed to be lit when input cables to a mixer are plugged in or are they always supposed to stay on regardless if cables are connected or not

#2 Tom Lureman

Tom Lureman

    Network Newbie

  • Admin
  • 111 posts

Posted 29 November 2011 - 11:04 AM

Hey man, I remember talking to you on the phone, and I still think you need to check out the amp in person with a set of speakers.  Even if they are small junky speakers, just to make sure there is no internally generated noise that is present when no input signal is connected.  It's possible it is just the input indicator circuit acting up and works fine, but it's hard to be sure without taking a look at it.

#3 knotter77

knotter77
  • Members
  • 4 posts

Posted 01 December 2011 - 08:09 PM

hey thanks for the response ... well i brought over some speakers to test also brought my SPD-S drum module... i have a 808 in G tuning.. sounds great except the drum module is noisy running thru( not an amp issue tho, its the drum module it sounds like that thru amps even hear that in monitor between songs ) anyways... i think i am gonna buy it... it drove my  15" carvins bridged at 4ohms loud,clear rumbling 808 subbass dropin G tuning check out despised icon band used in some thier songs