Jump to content


Kevin, xti4000 bridged for subs?


  • Please log in to reply
20 replies to this topic

#16 dakos

dakos

    Admin

  • Members
  • PipPipPipPipPip
  • 766 posts

Posted 11 October 2011 - 04:12 AM

QUOTE(Jon Cooper @ Oct 11 2011, 01:53 AM) View Post
Hey guys. Glad to be here. My question is why should you use a separate OmniDrive if the iTech's have one built in? Thanks

We were discussing using MA-i's and not i-tech's, if you plan to use i-tech's, especially the i-tech HD, then for a basic system there's no need for further processing.

#17 Jon Cooper

Jon Cooper
  • Members
  • 3 posts

Posted 11 October 2011 - 12:09 PM

QUOTE(dakos @ Oct 11 2011, 04:12 AM) View Post
QUOTE(Jon Cooper @ Oct 11 2011, 01:53 AM) View Post
Hey guys. Glad to be here. My question is why should you use a separate OmniDrive if the iTech's have one built in? Thanks

We were discussing using MA-i's and not i-tech's, if you plan to use i-tech's, especially the i-tech HD, there's no need for further processing.

Sorry about that. But thanks, that answered my question.

#18 glenn0

glenn0
  • Members
  • 18 posts

Posted 14 October 2011 - 01:03 PM

Thought I'd close the loop on this one.  I bought the MA9000i to power 2 SRX728S subs (4 ohms each) in stereo.  Used the xti6000 to power a pair of SRX725 tops also in stereo at 4 ohms.  All I can say is OMG!!!!!!!!  What a kick-*beep* system. Plenty-o-headroom to be sure and clean and punchy... Thanks for the advice....this was the ticket.

#19 dakos

dakos

    Admin

  • Members
  • PipPipPipPipPip
  • 766 posts

Posted 14 October 2011 - 01:13 PM

QUOTE(glenn0 @ Oct 14 2011, 01:03 PM) View Post
Thought I'd close the loop on this one.  I bought the MA9000i to power 2 SRX728S subs (4 ohms each) in stereo.  Used the xti6000 to power a pair of SRX725 tops also in stereo at 4 ohms.  All I can say is OMG!!!!!!!!  What a kick-*beep* system. Plenty-o-headroom to be sure and clean and punchy... Thanks for the advice....this was the ticket.

Good to know smile.gif


#20 Jon Cooper

Jon Cooper
  • Members
  • 3 posts

Posted 14 October 2011 - 02:18 PM

QUOTE(glenn0 @ Oct 14 2011, 01:03 PM) View Post
Thought I'd close the loop on this one.  I bought the MA9000i to power 2 SRX728S subs (4 ohms each) in stereo.  Used the xti6000 to power a pair of SRX725 tops also in stereo at 4 ohms.  All I can say is OMG!!!!!!!!  What a kick-*beep* system. Plenty-o-headroom to be sure and clean and punchy... Thanks for the advice....this was the ticket.

Hi Glenn
What kind of processing are you using?

#21 glenn0

glenn0
  • Members
  • 18 posts

Posted 18 October 2011 - 07:29 AM

Hey Jon, using a drive rack PA


QUOTE(Jon Cooper @ Oct 14 2011, 03:18 PM) View Post
QUOTE(glenn0 @ Oct 14 2011, 01:03 PM) View Post
Thought I'd close the loop on this one.  I bought the MA9000i to power 2 SRX728S subs (4 ohms each) in stereo.  Used the xti6000 to power a pair of SRX725 tops also in stereo at 4 ohms.  All I can say is OMG!!!!!!!!  What a kick-*beep* system. Plenty-o-headroom to be sure and clean and punchy... Thanks for the advice....this was the ticket.

Hi Glenn
What kind of processing are you using?