Jump to content


XTi 1000 Channel 1 Problem


  • Please log in to reply
3 replies to this topic

#1 Adrian StresS

Adrian StresS
  • Members
  • 5 posts

Posted 11 May 2011 - 07:40 AM

Hy. I have a XTi 1000 on my bench for 3 days now and i cant figure out why the power MJ's get very hot for no reason.
When the amp first came the MJE's exploded and the 3 diods next to the MJE 15033 shorted.
I changed the broken components and the amp works but in just a minute the MJ's all 6 of them on channel 1 get realy hot and Thermal led comes on.
I noticed that the MJ's PNP and NPN are shorted between each other channel 1 and channel 2 with some jumpers and i'm thinking there might be some feed-back between the channels.

Is there a update to the schematic or someting i could do to stop this from happening ?

Thank you.

I want to note that the display board is not the problem and all 6 MJ's had been changed just to make sure.

#2 Kip Whitehead

Kip Whitehead

    Power User

  • Members
  • PipPipPipPipPip
  • 32 posts

Posted 11 May 2011 - 10:04 AM

[quote name='Adrian StresS' date='May 11 2011, 08:40 AM' post='14648']
Hy. I have a XTi 1000 on my bench for 3 days now and i cant figure out why the power MJ's get very hot for no reason.
When the amp first came the MJE's exploded and the 3 diods next to the MJE 15033 shorted.
I changed the broken components and the amp works but in just a minute the MJ's all 6 of them on channel 1 get realy hot and Thermal led comes on.
I noticed that the MJ's PNP and NPN are shorted between each other channel 1 and channel 2 with some jumpers and i'm thinking there might be some feed-back between the channels.

Is there a update to the schematic or someting i could do to stop this from happening ?

Thank you.

When a driver fails and the diodes mentioned short, one there are 4 diodes which are D191, 180, 181 and 182, make sure all 4 are replaced as only 3 are mentioned. Also off the base of the drive mentioned, Q114 for channel 1, is a 340 Ohm resistor R147. That will open with a driver failure.

Next is to see what bias reads. This you measure from the driver heat sink to driver heat sink. So measure across the heat sinks of Q114 and 115. What does it read? As for this short between channels, what points are you measuring? The heat sins of each channel are tied to the same +/-30V so I need to know what points you are measuring to see this short as it may be a common ground or VCC point.


Thanks,

Kip

#3 Adrian StresS

Adrian StresS
  • Members
  • 5 posts

Posted 11 May 2011 - 10:47 AM


Thanks Kip for the replay.

I'm not at work but will do the measurements tomorrow and i will let you know.
Now about the PNP and NPN MJ's common +/-30V ... the Xti 2000, 3000 and 4000 has a lot of other components which controls power distribution to the MJ but are missing from the Xti 1000.
Anyway i will check everything tomorrow and let you know what's going on.

Thanks again.


#4 Adrian StresS

Adrian StresS
  • Members
  • 5 posts

Posted 12 May 2011 - 12:16 PM

That was it the two 340 Ohm resistors R147 and R148.

Thanks again Kip.