Jump to content


Old Reliable Power Base 2 Fan Speed Operation...


  • Please log in to reply
2 replies to this topic

#1 zylcho

zylcho
  • Members
  • 2 posts

Posted 03 April 2011 - 01:30 PM

This work horse has to be almost 10 years old and I can't say enough good things about this amp. I have had this amp fryin in the sun here (98 degrees plus) mono'd for hours on end and not one glitch. Even had a cup of beer splashed on it on a couple occasions. The last couple months the fan has been really loud. In the off season it is used less in an open air rack (by its lonesome). I don't believe this amp has a thermal sensor but I could be wrong. Religiously thoroughly cleaned, so not filthy.

Any assistance would be greatly appreciated.

Youtube video with top cover off...

Click Here.

#2 Tom Lureman

Tom Lureman

    Network Newbie

  • Admin
  • 111 posts

Posted 04 April 2011 - 09:39 AM

It's hard to tell from the video, but do you think it's caused by mechanical rattling?  I'm wondering if there is anything you can tighten to alleviate the noise.

#3 zylcho

zylcho
  • Members
  • 2 posts

Posted 09 April 2011 - 11:24 PM

QUOTE(Tom Lureman @ Apr 4 2011, 10:39 AM) View Post
It's hard to tell from the video, but do you think it's caused by mechanical rattling?  I'm wondering if there is anything you can tighten to alleviate the noise.



Thanks for the reply. Its definitely fan noise. I know the camcorder picked up other but its all fan "whoosing".

Its doing its job well, just never recalled it being that loud before.