Jump to content


Firmware updates for older XTi amps


  • Please log in to reply
1 reply to this topic

#1 Kevin Heber

Kevin Heber

    Power User

  • Crown Staff
  • 883 posts

Posted 24 March 2011 - 09:23 AM

NOTE:   The XTi2 series WILL NOT WORK WITH version 1 BAND MANAGER.  Please use System Architect or Band Manager 2 instead.

This patch is for older XTi amps that cannot communicate with Band Manager or System Architect.

Detach, unzip and run the EXE file, then upload whichever file it asks for (the S file or the HEX file).  After the upgrade, Band Manager/System Architect will be able to see the amp and complete the firmware upgrade to the most current version.  Make sure you are using the most current version of BM/SA to ensure you are getting the latest firmware.

IMPORTANT NOTE:  the CLoader.exe application will not run properly on Windows 7.

Attached Files



#2 kazakore

kazakore
  • Members
  • 3 posts

Posted 01 September 2012 - 10:01 AM

View PostKevin Heber, on 24 March 2011 - 09:23 AM, said:

IMPORTANT NOTE:  the CLoader.exe application will not run in Windows 7.

Saw this too late but I'd just like to say I successfully updated to 1.1.0.15 using the .hex and then to 1.1.3.11 using the .s files from a Win7 machine.