Jump to content


Perceived Low Power Output & SST Modules


  • Please log in to reply
1 reply to this topic

#1 Miles633

Miles633
  • Members
  • 1 posts

Posted 18 February 2005 - 03:31 PM

Hi -

I'm perceiving a lower output volume than I would expect from my system, and am wondering if it has to do with the way I've set it up or whether the SST module (type unknown) may have something to do with it.

The amp is a CE 2000 in stereo mode, with one side feeding parallel JBL M-Pro MP215's, and the other side feeding a JBL MP418S subwoofer.  The source is a Mackie 1604 board; the master output is usually around 0 dB or slightly less.  In the signal chain are an Alesis 31 band graphic EQ (the EQ master is not set for any attenuation) and a very old Tapco EV-18 crossover.  The crossover frequency is approx. 125 Hz.

The amp sensitivity is set to 1.4V.

The system sounds fine, but my experience with other amps of similar power is that I needed to keep the output level controls fairly low to keep from blowing the band out of the basement.   With this system, I can turn the level controls on the CE 2000 to about the "2" position before any significant feedback starts to occur, and even at that level the volume is not unreasonable for the basement.

Is there something about my setup that might cause this?  Also, I don't know if an SST module is installed, and if so what type it is.  I bought the amp new with no other sST hardware.   Could it be that the combination of my setup and an installed SST network could produce lower output?  Thank you!

#2 DGlass

DGlass

    .

  • Members
  • PipPipPipPipPip
  • 2,541 posts

Posted 18 February 2005 - 05:00 PM

Well without knowing which SST module that may or may not be installed in your amplifier and if it is good or bad I would be taking a stab in the dark.

The standard CE input module has no SST labeling on it. All other models of the SST's will be either have an SST-SBSC, SST-MX or SST-SX. Information on each can be found on the CE Accessories area of our web page.  http://www.crownaudio.com/amp_htm/ssts/ssts.htm

However this sounds like it may just be an input sensitivity question. Amplifiers from different manufactures and sometimes even between models will have different input voltages that will drive them to full rated output when the input attenuators are turned all the way up. The CE2000 comes with a customer selectable switch for 1.4 volts, which corresponds with the +4dBu level most professional gear works at, and a fixed gain of 26 db, which is used for DJ style mixers with a higher output level, and is 2.8 volts for the CE2000. The +4dBu for 1.4 volts correlates to the full output of a pro mixer and processing gear. So as you hit the pro gears full output you would be hitting the full output of the amplifier.

Some manufactures use a lower voltage to get the amplifier to full rated output and we even have a .775 volt setting on some amplifier models. This doesn't mean you get more power from the amplifier. It only means that you get to full output sooner with a lower input voltage going to an amplifier that has a lower input sensitivity voltage than one that has a higher input sensitivity voltage.