Jump to content


I-TECH IMP ERROR!


  • Please log in to reply
3 replies to this topic

#1 gil2th

gil2th
  • Members
  • 9 posts

Posted 10 December 2006 - 01:02 AM

HI!!    
    
     I HAVE I-TECH 6000 WITH JBL SR SERIES SUBS WORKING IN 4 OHMS  I HAVE A LOW IMPEDANCE ERROR REPORTING LEFT CHANNEL THAT SHOWS 2 OHMS AND IN RED COLOR, THE LOUDSPEAKER IS CONNECT CORRECTLY,  SO I DON'T KNOW IF  THIS COULD OVERHEAT THE POWER OR CAUSE ANY DAMANGE TO MY SPEAKERS, THANK YOU SO MUCH!!

#2 DGlass

DGlass

    .

  • Members
  • PipPipPipPipPip
  • 2,541 posts

Posted 11 December 2006 - 03:48 PM

The Itechs handle 2-ohm loads better than anything else. If the impedance were to get to low the amplifier would start going into protection before it would be damaged.

I'm not sure which model of SR sub you have so I can't make a complete evaluation of your situation. The IT6000, however, actualy drops about 500 watts in output power with a 2-ohm load per channel.

#3 gil2th

gil2th
  • Members
  • 9 posts

Posted 11 December 2006 - 08:11 PM

QUOTE(DGlass @ Dec 11 2006, 02:48 PM)
The Itechs handle 2-ohm loads better than anything else. If the impedance were to get to low the amplifier would start going into protection before it would be damaged.

I'm not sure which model of SR sub you have so I can't make a complete evaluation of your situation. The IT6000, however, actualy drops about 500 watts in output power with a 2-ohm load per channel.
View Post



Sorry for the incomplete question!! the subs I using are the  SR4719X 1200 watts  continuos 4ohms
one each channel and I have the amp out attenuator -25 dB. some times it's falls until 1 ohm, the connection are correct and I never let the input peak, what could be the problem??

#4 DGlass

DGlass

    .

  • Members
  • PipPipPipPipPip
  • 2,541 posts

Posted 03 January 2007 - 10:53 AM

Does this only happen on the Left channel no mater which of the speakers is attached?

If it does than it could possibly be a problem with either the sense circuit or the DSP. You might want to get it in to have our Service Dep't take a look at it.