Jump to content


XTi question


  • This topic is locked This topic is locked
4 replies to this topic

#1 jma_entertainment

jma_entertainment
  • Members
  • 3 posts

Posted 04 October 2006 - 02:46 PM

I was reading on some other forums that I would need to update the Firmware on my XTi before I can use the DSP's without any problems. I was looking at the update section and didn't see one for the XTi's. Is this true and if so, where do I get the update from.

-Thanks in advance!

#2 DGlass

DGlass

    .

  • Members
  • PipPipPipPipPip
  • 2,541 posts

Posted 04 October 2006 - 03:46 PM

I am attaching a link that will take you directly to the instruction page. This page will also have the link to get to the System Architect software site for the download. The download contains the software and firmware.

If your amp has firmware version 1.1.0.15 than you will not need to update. To check the firmware version:
With the amp turned on hold in the three front buttons for about 4 seconds. This will place the amplifier display in a diagnostic mode were individual channel temperatures, power supply temperature and firmware versions are displayed. You can step through the displays for each by using either the “Prev/UP” or the “Next/Down” buttons until you get to the firmware version. If it is less than 1.1.0.15 you will need to update the amps firmware before using your computer with the amp.

XTi_CDi_DSi firmware update

NOTE: Three .hex firmware files are provided one is for XTi amps, one is for CDi amps, and one is for DSi amps. Please make sure to select the proper model for the amp you own.

#3 jma_entertainment

jma_entertainment
  • Members
  • 3 posts

Posted 04 October 2006 - 04:00 PM

THANKS!

#4 jma_entertainment

jma_entertainment
  • Members
  • 3 posts

Posted 04 October 2006 - 07:26 PM

My amp reads FW 1. 0. 8.

This means I need the update right?

-Thanks,
Mike

#5 DGlass

DGlass

    .

  • Members
  • PipPipPipPipPip
  • 2,541 posts

Posted 05 October 2006 - 03:27 PM

QUOTE(jma_entertainment @ Oct 4 2006, 08:26 PM)
My amp reads FW 1. 0. 8.

This means I need the update right?

-Thanks,
Mike
View Post

If you want to use a computer and the System Architect software for custom settings than you will need to update.  biggrin.gif