Jump to content


Crown CE 2000


  • Please log in to reply
2 replies to this topic

#1 40dayman

40dayman
  • Members
  • 2 posts

Posted 27 September 2006 - 04:47 PM

Just purchased a 2 year old CE 2000 for our Church. It works great! I noticed though that the fan does not come on at start up. Is this normal and usually how long does it take to come on if it is normal?
Thanks!!

#2 DGlass

DGlass

    .

  • Members
  • PipPipPipPipPip
  • 2,541 posts

Posted 28 September 2006 - 10:26 AM

QUOTE(40dayman @ Sep 27 2006, 05:47 PM)
Just purchased a 2 year old CE 2000 for our Church. It works great! I noticed though that the fan does not come on at start up. Is this normal and usually how long does it take to come on if it is normal?
Thanks!!
View Post

The CE series uses Fan Assisted Cooling with a Proportional Speed Fan. In other word the fan will only come on when needed and only as fast as needed in relationship to the temperature inside. smile.gif

#3 40dayman

40dayman
  • Members
  • 2 posts

Posted 28 September 2006 - 03:56 PM

QUOTE(DGlass @ Sep 28 2006, 11:26 AM)
QUOTE(40dayman @ Sep 27 2006, 05:47 PM)
Just purchased a 2 year old CE 2000 for our Church. It works great! I noticed though that the fan does not come on at start up. Is this normal and usually how long does it take to come on if it is normal?
Thanks!!
View Post

The CE series uses Fan Assisted Cooling with a Proportional Speed Fan. In other word the fan will only come on when needed and only as fast as needed in relationship to the temperature inside. smile.gif
View Post

Thanks, I appreciate the feedback!!