Jump to content


PB-2


  • Please log in to reply
3 replies to this topic

#1 KenOB

KenOB
  • Members
  • 2 posts

Posted 02 August 2006 - 06:18 AM

Working on Crown Powerbase-2 with Main Board # Q43059-7 / D-7993-5 and Output Board # Q43203-1 / P10397-1...  Low high side bias with no adjustment possible... No obvious output transistor issues... Need real schematic for this combo of mainboard and output board - the pdf on web site is for an older mainboard.  Thanks in advance.

#2 Lou

Lou

    Power User

  • Members
  • PipPipPipPipPip
  • 62 posts

Posted 02 August 2006 - 12:32 PM

I guess you checked the pot. Check for your + and - bias voltages (collectors of Q 417 and 419). Should be approximately equal. Check for open ribbon cable connections. And lastly compare with the other side if its working. Good luck.

#3 KenOB

KenOB
  • Members
  • 2 posts

Posted 13 August 2006 - 10:39 AM

Thanks for the reply Lou,

Yea, I did check the pots, solder joints, bias circuit parts, etc, (all the normal stuff).  I did notice that the +VCC  went up to 91 volts upon power-up and the -VCC went to -2v (referenced to chassis) ....Compared with +/-50 on the good side.   That's why I posted looking for the real schematic.

After looking at the correct schematic for this mainboard & amp combo, which is Crown Drawing # J0697-3 (thanks to Crown Tech support),  I found Q216 (pre-driver) shorted in the "low side"...  Replaced it and all is well.

#4 Lou

Lou

    Power User

  • Members
  • PipPipPipPipPip
  • 62 posts

Posted 17 August 2006 - 09:06 AM

There's a 200 ohm resistor that goes open in there too. But you'll probably see that visually!