Jump to content


Crown XLS 602 buzzing sound and unable to power speakers.


  • Please log in to reply
4 replies to this topic

#1 MaitreG

MaitreG
  • Members
  • 4 posts

Posted 10 October 2011 - 10:25 AM

I am so glad that I found this site and hope that I can be helped.
I bought this beautiful new Crown XLS 602 a few years ago. The only number over the barcode is 304378. It started to give me a buzzing sound like a bad jack. As I try to increase the volume (regardless of level) of the music, it would sound distorted and unable to bring a clear regular sound. It is unable to power the speakers on both channels equally. Pre-amp, the sound is clear with a headphone or connected to another amplifier.  I called Crown customer service, out of warranty, and was told to bring it to an authorized dealer which I did 7/16/2010. They fixed it and I was told that transistors needed to be replaced.  On the receipt it says that they replaced four NPN MJ15024 TO-3 and four MJ15025 TO-2 TO-204A transistors.
Last month, it started doing the same thing again. I took it to the same authorized dealer and was given a 400 dollar estimate. I cannot possibly pay this kind of money that I think I bought the amp for a few years ago along with a full compatible sound system.  It is imperative that my mini studio comes alive.
I am afraid that it will continue to do this. Now this is my dilemma, do you think this is the problem based on their diagnosis, when replacing transistors, isn't it recommended to replace all of them? What can I do if I wanted to replace them myself and can Crown sell me the parts as I accept full responsibility?
Any help in this matter will greatly be appreciated.
Thanks!  sad.gif

#2 Kevin Heber

Kevin Heber

    Power User

  • Crown Staff
  • 883 posts

Posted 11 October 2011 - 10:57 AM

You can purchase these from Crown parts at roughly $14 per transistor.  I do trust our service centers to be fair & honest, however.  It sucks that this happened twice now -- is there anything unusual about your setup?

#3 MaitreG

MaitreG
  • Members
  • 4 posts

Posted 12 October 2011 - 07:42 AM

QUOTE(Kevin Heber @ Oct 11 2011, 11:57 AM) View Post
You can purchase these from Crown parts at roughly $14 per transistor.  I do trust our service centers to be fair & honest, however.  It sucks that this happened twice now -- is there anything unusual about your setup?


Thanks for replying Kevin. I spoke with Crown and am in the process of getting the shipping documentation for the factory. The authorized Dealer is full of it as far as I am concerned. I only wished that Crown never referred me to them and insisted on having it sent.

Again thanks!

#4 MaitreG

MaitreG
  • Members
  • 4 posts

Posted 24 November 2011 - 08:48 AM

QUOTE(MaitreG @ Oct 12 2011, 08:42 AM) View Post
QUOTE(Kevin Heber @ Oct 11 2011, 11:57 AM) View Post
You can purchase these from Crown parts at roughly $14 per transistor.  I do trust our service centers to be fair & honest, however.  It sucks that this happened twice now -- is there anything unusual about your setup?


Thanks for replying Kevin. I spoke with Crown and am in the process of getting the shipping documentation for the factory. The authorized Dealer is full of it as far as I am concerned. I only wished that Crown never referred me to them and insisted on having it sent.

Again thanks!



Now it has been more than a month since my Crown was sent to Crown for service. I was never told there was a 25 days period before it is diagnosed until I contacted customer service by phone. More then 25 days later, I called and left a message. I decided to e-mail customer service to be told there was another 25 days period.
After this first 25 days, I must wait another 25 days till I get a response. In the mean time, Thanksgiving is here and the holidays are fast approaching.
I tend to be loyal to a brand and company, but this relationship with this amp and the company is looking bleak. I am seeing other brands more powerful selling for less than the price of the repair I incurred so far on this Crown, even this repair.

I have a problem with companies and people not being upfront before a contract is initiated. I am propelled to contact every governmental entity to let them know how I was treated. It becomes a matter of principle. I do not expect a positive end to this transaction. I feel as if I fell for a scam. mad.gif

#5 MaitreG

MaitreG
  • Members
  • 4 posts

Posted 07 December 2011 - 05:58 PM

QUOTE(MaitreG @ Nov 24 2011, 08:48 AM) View Post
QUOTE(MaitreG @ Oct 12 2011, 08:42 AM) View Post
QUOTE(Kevin Heber @ Oct 11 2011, 11:57 AM) View Post
You can purchase these from Crown parts at roughly $14 per transistor.  I do trust our service centers to be fair & honest, however.  It sucks that this happened twice now -- is there anything unusual about your setup?


Thanks for replying Kevin. I spoke with Crown and am in the process of getting the shipping documentation for the factory. The authorized Dealer is full of it as far as I am concerned. I only wished that Crown never referred me to them and insisted on having it sent.

Again thanks!



Now it has been more than a month since my Crown was sent to Crown for service. I was never told there was a 25 days period before it is diagnosed until I contacted customer service by phone. More then 25 days later, I called and left a message. I decided to e-mail customer service to be told there was another 25 days period.
After this first 25 days, I must wait another 25 days till I get a response. In the mean time, Thanksgiving is here and the holidays are fast approaching.
I tend to be loyal to a brand and company, but this relationship with this amp and the company is looking bleak. I am seeing other brands more powerful selling for less than the price of the repair I incurred so far on this Crown, even this repair.

I have a problem with companies and people not being upfront before a contract is initiated. I am propelled to contact every governmental entity to let them know how I was treated. It becomes a matter of principle. I do not expect a positive end to this transaction. I feel as if I fell for a scam. mad.gif


I received my Crown back yesterday and it's working like a charm. Hope it keeps going for the next 30 years. I am just vicious without my mini studio working.rolleyes.gif

PS. I think Crown should stop referring people to the authorized dealer in Miami, they are a reap off and don't know what they are doing.  

Thank you!