Jump to content


K 1 Noisy pot on channel one


  • Please log in to reply
2 replies to this topic

#1 rosskalla

rosskalla
  • Members
  • 2 posts

Posted 10 September 2005 - 06:58 AM

HI all
I'm using a K1 for my bass and I'm very happy with my sound.
I've developed a nasty crunchy, crackling sound when I turn my level control.  Is there anything I can do about it?

Regards

Ross

Australia

#2 KWhitehead

KWhitehead

    Power User

  • Crown Staff
  • 34 posts

Posted 11 September 2005 - 02:13 AM

Sometimes rotating the pot back and fourth several times will clean out the contacts. Otherwise you need to open the amplifier up and remove the display board the pots are attached to and use contact cleaner sprayed inside the pot. If this needs to be done I would contact your distributor which is Jands to have them perform the cleaning.

Thanks,

Kip Whitehead
Crown Technical Support

#3 rosskalla

rosskalla
  • Members
  • 2 posts

Posted 11 September 2005 - 02:20 AM

QUOTE(KWhitehead @ Sep 11 2005, 02:13 AM)
Sometimes rotating the pot back and fourth several times will clean out the contacts. Otherwise you need to open the amplifier up and remove the display board the pots are attached to and use contact cleaner sprayed inside the pot. If this needs to be done I would contact your distributor which is Jands to have them perform the cleaning.

Thanks,

Kip Whitehead
Crown Technical Support
View Post


Thanks Kip, much appreciated.  Jands is about 600 miles from here, so I'll have a cautious look meself.

Kind regards

Ross