Jump to content


USP/2 Impedance Calibration


  • Please log in to reply
3 replies to this topic

#1 dynamic

dynamic
  • Members
  • 6 posts

Posted 24 May 2006 - 09:21 PM

Hi,  
I was hoping someone can assist me in finding and correcting a false reading I'm getting from one of my Crown 5002's equipped with USP/2 cards.

Amp #1 (5002) has a USP/2 V.  1.003
Amp #2 (5002) has a USP/2 V.  1.010

I have had to adjust the scaling switches so at least the I/O on both cards read the same. (I think they were both happy at what ended up to be the +10dB setting).
And not on each I may add, the output scaling on amp #1 differs from the other by + 10dB.

By the way, I think EVERYBODY prefered the older "card cage" instead of the IQII's two snap-in ribbon cables. Nice way to increase the odds of snapping components off the card. Much carefulness needed.

So what is currently the issue: Both amps set up the same, both amps driving the same load, (very expensive, and quite precision transducers) and cable size and lenghth. All the real elementary stuff checked.
Amp #1 (v 1.003) will consistently read higher impedance 11-14 ohms, whilst amp#2 (v 1.010) will fluctuate in it's reading (as amp#1 does too) BUT, its' reading closer to the actual load of 8 Ohms.

It has been a chore to get these two firmware versions to operate identically. I have also read  other posts of companies who also have issues with these two different versions.  
Is it possible to turn a v 1.003 into a v 1.010 by replacing the IC Chip to the newer version? Or can these two readings be explained/ corrected another way???

Thank you in advance for your help,
Rick

#2 DGlass

DGlass

    .

  • Members
  • PipPipPipPipPip
  • 2,541 posts

Posted 25 May 2006 - 09:19 AM

With all the amp functions the newer PIP cards need to monitor the original PIP 1 card cage did not have enough connections to provide this needed information. Going to a different edge card connector with smaller connectors would have added a lot more to the cost of the PIPs and the amps. The ribbon cables were a way of providing a cost effective alternative as well as being able to keep some backwards compatibilities to some of the original non-IQ pips. In most cases by using the "USP-2 Adapter" card a PIP1 edge card PIP could be used in a ribbon cabled PIP2 amp.

I can't explain what is going on with the load monitoring issues you are seeing but there is something more going on here than just firmware differences.
If you want to keep both USP-2 modules at the same firmware versions the USP-2 v 1.010 firmware chip can be purchased from our Parts Department here at Crown. It is part number 126634-5.

Instructions for upgrading:

1) Using a PLCC chip extractor tool and standard static precautions.( i.e. ground strap) remove the older version firmware chip.
2) Install the new chip into the socket.

Note: Chip and socket are keyed, in one corner, and the chip will only install in one direction.

3) With the AC power switched off install the PIP module into a CTs amplifier.
4) On the face plate of the PIP near the Data light will be small unlabelled hole.    Inside this hole is a micro switch.
5) Using a small tool, such as large paperclip, a 1/16” or 1.5 mm hex key depress the micro switch.
6) While depressing the micro switch turn on the amplifier.
7) Count up to six flashes of the Data and Preset lights. Remove the tool from the reset hole.
8) The Data and the Preset lights will flash alternately and then the Data light will flash several times on it’s own.
9) Firmware has now been reflashed into memory and updated.

Note: IQ for Windows 5.12 must be used with the updated firmware.
         Older software will not recognize the newer firmware.

10) Verification of update should be done with the IQ for Windows 5.12 software. In the “General” information panel of the devices Control Panels is a firmware listing.

#3 dynamic

dynamic
  • Members
  • 6 posts

Posted 25 May 2006 - 12:17 PM

QUOTE(DGlass @ May 25 2006, 09:19 AM)
With all the amp functions the newer PIP cards need to monitor the original PIP 1 card cage did not have enough connections to provide this needed information. Going to a different edge card connector with smaller connectors would have added a lot more to the cost of the PIPs and the amps. The ribbon cables were a way of providing a cost effective alternative as well as being able to keep some backwards compatibilities to some of the original non-IQ pips. In most cases by using the "USP-2 Adapter" card a PIP1 edge card PIP could be used in a ribbon cabled PIP2 amp.

I can't explain what is going on with the load monitoring issues you are seeing but there is something more going on here than just firmware differences.
If you want to keep both USP-2 modules at the same firmware versions the USP-2 v 1.010 firmware chip can be purchased from our Parts Department here at Crown. It is part number 126634-5.

Instructions for upgrading:

1) Using a PLCC chip extractor tool and standard static precautions.( i.e. ground strap) remove the older version firmware chip.
2) Install the new chip into the socket.

Note: Chip and socket are keyed, in one corner, and the chip will only install in one direction.

3) With the AC power switched off install the PIP module into a CTs amplifier.
4) On the face plate of the PIP near the Data light will be small unlabelled hole.    Inside this hole is a micro switch.
5) Using a small tool, such as large paperclip, a 1/16” or 1.5 mm hex key depress the micro switch.
6) While depressing the micro switch turn on the amplifier.
7) Count up to six flashes of the Data and Preset lights. Remove the tool from the reset hole.
8) The Data and the Preset lights will flash alternately and then the Data light will flash several times on it’s own.
9) Firmware has now been reflashed into memory and updated.

Note: IQ for Windows 5.12 must be used with the updated firmware.
         Older software will not recognize the newer firmware.

10) Verification of update should be done with the IQ for Windows 5.12 software. In the “General” information panel of the devices Control Panels is a firmware listing.
View Post



Hi David,
Thank you for your quick response to my inquiry. You guys do a great job in support of your products, and that really means a lot to all of us out here.

I detected a little defensiveness with the ribbon cable issue, please forgive me, I didn't mean to give a hard time. I was into this stuff back when you guys were going from PIP-I to PIP-II and I had realized there were "real-estate" issues with the amplifiers interior space even then (MA-3600) for example.

Thanks again for your detailed instruction (and part #), and keep up the great work!
Rick

#4 DGlass

DGlass

    .

  • Members
  • PipPipPipPipPip
  • 2,541 posts

Posted 25 May 2006 - 12:36 PM

My apologies I didn't mean to come off sounding defensive. unsure.gif  I just wanted to clear up why we went that direction. smile.gif