Jump to content


Community Status Updates


tvyankee's Photo
ward1709's Photo
dallashands's Photo
sordell508's Photo
keogh575's Photo

keogh575

http://www.rearmyourselfclearlaketx.com - Dr. Budoff’s focus is on restoring function and eliminating pain with the least invasive method possible.
May 20 2014 09:26 PM
Mctwins's Photo

Mctwins

Why can't I post in this forum?
May 17 2013 05:01 AM
  • dakos's Photo
    dakos
    Are you still unable to post?
    Apr 29 2014 02:52 AM
  • Mctwins's Photo
    Mctwins
    Thanks Dakos, I think I can post now. I will give it a try. Don't know what when't wrong and the reason I coulden't post.

    Mctwins
    Jun 20 2014 04:16 AM
renaissancemannc's Photo

renaissancemannc

Need help setting up PA for drum micing
Nov 20 2012 09:16 AM
prapol's Photo

prapol

I am quite new with ITech 12000 HD. Is it ok to use Belden 1305A connect with RAck Amp ( a cable long 100 metre )
Nov 09 2012 01:53 AM
smiles's Photo

smiles

post a question
Jul 31 2012 11:30 PM
mdlowe's Photo

mdlowe

NEVER MIND!!!
I fidddled around and fixed my own problem. I have to say the doc leaves a lot to be desired!
Oct 17 2011 12:02 AM
Pierre Richard Dorce's Photo

Pierre Richard Dorce

I need help setting up my system
Apr 04 2010 02:43 PM
gcantu's Photo

gcantu

tengo un problema con un crown xti 2000
en la pantalla lcd me muestra loked y no me da salida de sonido gracias
Jan 28 2010 01:57 AM
JoeBLaNCo24's Photo

JoeBLaNCo24fbtmaxx

I'm Looking For A Real Great Amp That Can Hold My Four JL Audio 13W7-D1.5.
Free Air Resonance (Fs): 23.5 Hz
Electrical Q (Qes): 0.476
Mechanical Q (Qms): 7.517
Total Speaker Q (Qts): 0.448
Equivalent Compliance (Vas) 3.68 cu. ft. / 104.3 liters
One-Way, Linear Excursion (Xmax)*: 1.25 in. / 32 mm
Reference Efficiency (no): 0.269% May 05 2009 12:58 PM
STEVEN G's Photo

STEVEN G

Is there nobody that can help me with this?
Kinda thought this would be the best place to get some suggestions.
Apr 30 2008 10:05 AM
Edwin Benavides's Photo

Edwin Benavides

does anybody know how to unlocked de xti 1000 amplifier. i was setting up the limiter and it was locked automatically. when i use the IQ software id appears to be off line
Dec 13 2007 05:34 PM