Hamilton

DC 300 - low output

9 posts in this topic

Hi,

I have purchased a DC300 on eBay that seems to have really low output. There are no issues with hum or noise and the audio quality is very good. But...this thing is getting trampled by a half-sized Halfer 1500. :blink:

The label on the back says "120 volts" which is correct for where I live.

Thanks for the help,

Hamilton

Share this post


Link to post
Share on other sites
 

Hi, 

 

I have purchased a DC300 on eBay that seems to have really low output.  There are no issues with hum or noise and the audio quality is very good.  But...this thing is getting trampled by a half-sized Halfer 1500.  :blink: 

 

The label on the back says "120 volts" which is correct for where I live.   

 

Thanks for the help, 

Hamilton 

2429[/snapback]
 

Hi Hamilton,

You will probably hear from some of the real pros about this, however unless you have a problem with your DC300, which I doubt, I suspect you are not driving it with the needed input. I drive mine with a Makie 1402VLZ running the +4dBu output setting and do just fine. If you read other posts on this site there are many listings about using pro auto gear with home type preamps. There are references to matching boxes from Rolls. That may be your problem as you did not mention what you are using to drive your DC300. My DC300A will output chest thumping bass through 2 EV215 bass boxes. Congrats on the new DC300, I have owned mine for over 20 years and still use it every day. :) It is surly one of the best amps ever made. As for 120 volts, the DC300A can be internally re-wired for other voltages, however I have no idea what the amp would do if it were wired for, lets say 220v. Probably something MUCH worse than just low audio. Good luck, Bob B)

Share this post


Link to post
Share on other sites

Hey Bob, thanks for the reply. Here's what I have working, it's pretty simple.

I have built some crossovers from JBL's nL200t3 schematic for the home theater surrounds and I'm running a CD player straight into the DC300 for testing. But the SPL is low enough that the tests are really not that valid; only about 70 db pink noise.

So I reinstalled the Hafler 1500 (75 watts per channel) and it cranks out easy 90 db pink noise.

Maybe you're right about the frontend of the DC300 being padded down compared to home audio/studio stuff.... Unfortunately, the CD player does not have an output adjustment.

Thanks for taking the time,

Hamilton

Share this post


Link to post
Share on other sites
Hey Bob, thanks for the reply. Here's what I have working, it's pretty simple. 

I have built some crossovers from JBL's nL200t3 schematic for the home theater surrounds and I'm running a CD player straight into the DC300 for testing. But the SPL is low enough that the tests are really not that valid; only about 70 db pink noise.

So I reinstalled the Hafler 1500 (75 watts per channel) and it cranks out easy 90 db pink noise.

Maybe you're right about the frontend of the DC300 being padded down compared to home audio/studio stuff....  Unfortunately, the CD player does not have an output adjustment.

Thanks for taking the time,

Hamilton

2446[/snapback]

Hi Hamilton,

I looked up the input sensitivity for the DC300, 1.75v for full output. I suspect your CD player is no where near that. Look up a post on the general discussion side of this forum dated 10/29/05 "Crown amps for home audio use." There is a ton of information there. Good luck! Bob B)

Share this post


Link to post
Share on other sites
Hey Bob, thanks for the reply. Here's what I have working, it's pretty simple.

I have built some crossovers from JBL's nL200t3 schematic for the home theater surrounds and I'm running a CD player straight into the DC300 for testing. But the SPL is low enough that the tests are really not that valid; only about 70 db pink noise.

So I reinstalled the Hafler 1500 (75 watts per channel) and it cranks out easy 90 db pink noise.

Maybe you're right about the frontend of the DC300 being padded down compared to home audio/studio stuff....  Unfortunately, the CD player does not have an output adjustment.

Thanks for taking the time,

Hamilton

2446[/snapback]

If you are trying to drive the DC300 straight from a CD player you will not have enough drive voltage to get the DC300 to full rated output. You will need a Preamp that can do close to 2 volts output to get the DC300 to full output. The input sensitivity of the DC300 series was 1.75 volts and most CD players will usually only do a few millivolts output. :blink:

Share this post


Link to post
Share on other sites

Thanks guys, it's great knowing that my *new* amp is just fine. I appreciate all the help and responses, please have a great Christmas.

Hamilton

Share this post


Link to post
Share on other sites
I have wondered a few times...

that 1.75 volts, is that peak to peak?

Isn't most pro audio gear 1 volt P-P?

5360[/snapback]

The reason for this was that back then amps were set for a fixed amplifier gain not a fixed voltage input as fixed gain gave the best signal to noise. There were a couple of different db gains used by several manufactures. In the case of our amps it was 26db of gain and is the reason we carried the 26db gain setting for so long on other of our amplifier lines.

Using a fixed gain is actually a better but more complex way of doing gain structure. With a fixed gain the input voltage required to obtain full output was different between every model of amplifier and required some knowledge of speaker effencies to be able to balance out a system.

With fixed voltage you know that the all the amps will reach full output at the same time if the input attenuators are set wide open. If something is to loud you can turn down the amplifier input attenuator to compensate.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now