phatter

Crown XTI 1002 amp in 4 ohm mode

6 posts in this topic

Hi,

i seem to be missing something,

i have 4 ohm per channel speakers that are rated for 200W Continuous, 800W Peak watts, but i can't seem to find how to setup the amp for them. i'm assuming they are running on 2 ohms now.

Share this post


Link to post
Share on other sites

What kind of setup are you looking for??? You just have to plug the speaker and play music, what brand,model of speaker are you refering to? Speaker are not running anything amplifier will though.

Share this post


Link to post
Share on other sites

i Have a Crown XTI 1002 and JBL LSR 6332 speakers, i don't know why it sounds so much better in Bridge mode, not only close range, can also hear it better from a distance,

Share this post


Link to post
Share on other sites

Those speaker are rated 4 ohms so you cannot hookup two in parrallel on your amp in bridged mode. You should set your amp in stereo mode.

Share this post


Link to post
Share on other sites

Hello there,

I don't know how you connected them but it sounds to me that you have one speaker with reversed polarity and when you have them connected in bridge you're connecting them differently, with the correct polarity. So, check your cables and get back to us.

Avi

Share this post


Link to post
Share on other sites

Hi,

i got it, a tweeter was blown on one of my speakers and that made it seem like bridge mode improved the sound, but now with tweeter replaced they sound awesome on Stereo mode. thanks,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now