Sign in to follow this  
Followers 0
CarolinaCrown

D150A II problems

7 posts in this topic

Hey folks, I'm new to this forum and I'm having a little problem with a D150A II. Both 15003's are blown plus several resistors and a power transistor. I have all the schematics plus the service manual. My main problem is cross referencing the transistors. Mainly its Q107 , p# C 4061-5, its a D40V2 tranny. I've already replaced several caps, diodes, and the zener diodes. I know I can order parts through Crown but I'd rather get parts on my own. All help is greatly appreciated,Greg

Share this post


Link to post
Share on other sites

Come on folks. No one has a possible cross reference tranny list? I've search the net with limited luck. I'm guessing no knows about these dinosaurs but it was worth a shot . Maybe another electronics forum would be better.

Share this post


Link to post
Share on other sites

Hey CC, The C 4061-5 is still available from Crown. It may also be available under C 5065-5. Good luck!

Share this post


Link to post
Share on other sites

Try National Semi, NSD-128. I'm not sure if this part is still available. That's the only info I have on this substitute.

It appears that the C4061 is also subbed as C5065-5. This one is subbed from GE, D40P3. I don't have info on this one.

Though, try to get the original Crown p/n! It may still be available.

Share this post


Link to post
Share on other sites

Thanks joust! I think I'll have to bite the bullet and order 'em from crown. But at least I'll know they're the right part. Right??

Thanks again for your input,Greg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0