Sign in to follow this  
Followers 0
zylcho

Old Reliable Power Base 2 Fan Speed Operation...

3 posts in this topic

This work horse has to be almost 10 years old and I can't say enough good things about this amp. I have had this amp fryin in the sun here (98 degrees plus) mono'd for hours on end and not one glitch. Even had a cup of beer splashed on it on a couple occasions. The last couple months the fan has been really loud. In the off season it is used less in an open air rack (by its lonesome). I don't believe this amp has a thermal sensor but I could be wrong. Religiously thoroughly cleaned, so not filthy.

Any assistance would be greatly appreciated.

Youtube video with top cover off...

Share this post


Link to post
Share on other sites

It's hard to tell from the video, but do you think it's caused by mechanical rattling? I'm wondering if there is anything you can tighten to alleviate the noise.

Share this post


Link to post
Share on other sites
It's hard to tell from the video, but do you think it's caused by mechanical rattling? I'm wondering if there is anything you can tighten to alleviate the noise.

Thanks for the reply. Its definitely fan noise. I know the camcorder picked up other but its all fan "whoosing".

Its doing its job well, just never recalled it being that loud before.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0