beek

K-1 dropouts

7 posts in this topic

I have a 5 year old K-1 thats serves home audio sub duty. After a few hours the right channel cuts out, after turning off for awhile it comes back on for a few more hours. Any ideas what I could look at before deciding what to do with this unit? Any help would be appreciated.

Thanks Bill

Share this post


Link to post
Share on other sites

I would suggest to swap inputs first to see if it changes sides. If not, then swap outputs. If it sticks to the right channel, time for service. Doesn't appear to be anything major, however.

Share this post


Link to post
Share on other sites
I would suggest to swap inputs first to see if it changes sides. If not, then swap outputs. If it sticks to the right channel, time for service. Doesn't appear to be anything major, however.

Share this post


Link to post
Share on other sites
I would suggest to swap inputs first to see if it changes sides. If not, then swap outputs. If it sticks to the right channel, time for service. Doesn't appear to be anything major, however.

Thank You Kevin, was wondering should I order all the right channel boards and drop them in?

Share this post


Link to post
Share on other sites

There is one output board assembly for each channel that run about $250 per board. The problem is almost certainly in the output stage but the economics are left to your decision.

Share this post


Link to post
Share on other sites
There is one output board assembly for each channel that run about $250 per board. The problem is almost certainly in the output stage but the economics are left to your decision.

Thanx Again Kevin Where can I find the board P/N ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now