Sign in to follow this  
Followers 0
R8DER

Crown XS1200 Fault light

5 posts in this topic

Just yesterday I was DJing at an event, lead singer of the band used my mic for singing and clipped my xs1200 into fault mode and now it wont turn back on. the ac main and fault light just stay on amp doesnt power up. Did I fry something or could it be just a fuse? It doesnt smell burned or anything. Please help I need to get this amp up and running asap for my next gig. Thanks

Share this post


Link to post
Share on other sites
The amp just needs to get into service, unfortunately.

how would I go about doing that? Amp is not under warranty anymore :(

Share this post


Link to post
Share on other sites

In the USA, you can get it to one of our regional service centers - http://www.crownaudio.com/support/servcent.htm

or call 800-342-6939 to send it to the factory for service.

For other countries, find your service center/distributor here: http://www.crownaudio.com/gen_htm/distribselect2.php

Or, contact your favorite electronic repair guru and we can send them the schematics to fix it.

Share this post


Link to post
Share on other sites
In the USA, you can get it to one of our regional service centers - http://www.crownaudio.com/support/servcent.htm

or call 800-342-6939 to send it to the factory for service.

For other countries, find your service center/distributor here: http://www.crownaudio.com/gen_htm/distribselect2.php

Or, contact your favorite electronic repair guru and we can send them the schematics to fix it.

Ok thanks! Can you send me the schematics for the crown xs1200 please? Sickness515006@yahoo.com

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0