HiQnet not working.

6 posts in this topic


I can run HiQnet on my laptop no problems, however I would also like to run it on my main PC in my office as I sit here mostly and would like to get back into designing some custom panels.

This PC used to run HiQnet SA without problems, then all of a sudden it stopped working,, and now no matter which version I install it gives the the same error messages upon startup.


I have added this program to my firewall and AV program and given it full access, however it still reports some kind of security problem.

This machine is now running XP SP3, which ever is the latest MS available version via Windows update.

Any help would be great and if possible could this be forwarded to the correct person who might be able to assist.

This first appeared when I attempted to upgrade to SA 1.6, from that point NO versions of SA will work on this Machine.

Thanks for any time.

Share this post

Link to post
Share on other sites

It looks like something is going on with the Windows Registry that is not allowing the program to start.

Have you tried uninstalling the System Architect program, deleting all the System Architect folders in the C:\Program Files\Harman Pro directory and reinstalling the program?

Also make sure the Windows Firewall is shut off and that you have administrator privileges for that machine.

Since the software is produced by the Harman-Software Development Group I have fowarded the question over to them as well.

Share this post

Link to post
Share on other sites

Well you have the guys at Harman SDIG stumped as well. Here is what I have received back from them:


The splash screen uses a registry entry in order to increment the scroll bar across the bottom of the splash screen when you launch SA. The installer adds these initially and SA uses them the first time it starts and then updates them to the speed of the system being used.

So, the questions that need to be asked are as follows:

1. Was Sys. Arch. installed as one user, then switch to another user account to launch it?

In either case...

2. Check the registry at //HKEY_CURRENT_USERS/Software/HarmanPro/System Architect 1.70/ and make sure the values Increment, Percents, and RecentFile exist. If they do not exist, have him import the registry file I've attached to this email. This will add these keys and values if they are missing.


Note: I will email you the registry file. Also since you are using this at work make sure your IS people know what you are doing just incase you are violating any corporate policies.

Share this post

Link to post
Share on other sites

Still no joy here David.

I will get more time after this coming weekend to have a deeper look into this.

My machine here is dual boot with XP Pro SP3 and Vista Ultimate, so maybe that has somehow caused a problem?

It's getting ready for a new HDD soon , so I'll re-build the entire system and hopefully SA should load in fine.

Thanks for your efferts so far, much appreciated.

Share this post

Link to post
Share on other sites

David and SA team,

I have now managed to install SA R1 and have it fully working.

I am not going to tempt fate and reverse any installs at this point to figure out why or what caused the previous few months of not getting SA to work on this particular machine, however I can list the steps taken that have allowed me to proceed.

1) Removal of SA (control panel add/remove progs)

2) Deletion of entire SA dire structure from machine (via exlporer)

3) Removal of .NET framework V3 (control panel add/remove progs)

4) Removal of .NET framework V2 (control panel add/remove progs)

5) Removal of SQL Compact Server V3.5 (control panel add/remove progs)

6) Uniblue Registry tool used to clean up any registry fragments

7) Re-download of latest SA complete with .NET framwork V2

8) Install complete and program loads and runs fine.

So in summary, the only rogue item here might be the .NET Framework V3 which could have caused some conflict maybe?

Hope this info helps the SA team in case ony of them are scratching their heads over the previously posted error screens. (which occurred for any version 1.40.1 up to

Share this post

Link to post
Share on other sites

Since you also used a Registry cleaner it could also have been a corrupted registry entry. I have passed what you did over to the SA development team. I am glad to hear you have it working. :)

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now