Sign in to follow this  
Followers 0
KenOB

PB-2

4 posts in this topic

Working on Crown Powerbase-2 with Main Board # Q43059-7 / D-7993-5 and Output Board # Q43203-1 / P10397-1... Low high side bias with no adjustment possible... No obvious output transistor issues... Need real schematic for this combo of mainboard and output board - the pdf on web site is for an older mainboard. Thanks in advance.

Share this post


Link to post
Share on other sites

I guess you checked the pot. Check for your + and - bias voltages (collectors of Q 417 and 419). Should be approximately equal. Check for open ribbon cable connections. And lastly compare with the other side if its working. Good luck.

Share this post


Link to post
Share on other sites

Thanks for the reply Lou,

Yea, I did check the pots, solder joints, bias circuit parts, etc, (all the normal stuff). I did notice that the +VCC went up to 91 volts upon power-up and the -VCC went to -2v (referenced to chassis) ....Compared with +/-50 on the good side. That's why I posted looking for the real schematic.

After looking at the correct schematic for this mainboard & amp combo, which is Crown Drawing # J0697-3 (thanks to Crown Tech support), I found Q216 (pre-driver) shorted in the "low side"... Replaced it and all is well.

Share this post


Link to post
Share on other sites

There's a 200 ohm resistor that goes open in there too. But you'll probably see that visually!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0