athamay

Members
  • Content count

    10
  • Joined

  • Last visited

Community Reputation

0 Neutral

About athamay

  1. thanx very much for your time, i'll be home wednesday and let you know if i got it all working
  2. god i'm going to sound stupid but don't quite understand that, are you saying i don't just plug in the speakon connectors as normal but have to do something else with them 1st??? as i undo them and rewire or something? i did read that but made little sense to me, as it doesn't picture how to acheve this does this mean i have to plug in speakons upside down or take both ends of the speakons and rewire them differently, so as no diagrams in user book finding it are to understand ok i've done my homework on rewiring now and some speak on charts and now understand what i need to do, thank you for your time, i've woken up from the dumb moment now, lol
  3. god i'm going to sound stupid but don't quite understand that, are you saying i don't just plug in the speakon connectors as normal but have to do something else with them 1st??? as i undo them and rewire or something? i did read that but made little sense to me, as it doesn't picture how to acheve this does this mean i have to plug in speakons upside down or take both ends of the speakons and rewire them differently, so as no diagrams in user book finding it are to understand
  4. god i'm going to sound stupid but don't quite understand that, are you saying i don't just plug in the speakon connectors as normal but have to do something else with them 1st??? as i undo them and rewire or something? i did read that but made little sense to me, as it doesn't picture how to acheve this
  5. How did you connect the speaker to the amp? What cable? What connector? And how did you connect the wires to the connector? What setting did you use on the amp? hi i used some heavy duty speakon 4core cables, all connections where made through channel one for inputs and the speakers out, i've done everything it says on the tin to wire it up re the instructions in the book, i just can't understand why its not working, my speakers can handle the amps, and like i said just in case it was the gain on the mixer i also took this out of the link and sent the signal direct, " wasn't my laptop either " as i tried my macbook and a windows laptop which work perfectly, i'm totally mystified
  6. hi there, i just received my 2nd els 2000 amp and was wanting to run each off my speakers in bridge mono for each speaker, i have tried various wired up configurations and all it keeps doing is clip with little or no power of sound, i have sent signal direct to amps or has been put through my alexis multi mix 8 which i always ran perfectly with my unmark dimension 4 amp in mono bridge without this problem only way i seem to get my speakers working properly is in stereo, i have tried it in all by pass modes as well any ideas why it doesn't work ? i'm running peavey hisys rx2's 500w cont, 1000w program 2000w peak, really haven't got a clue what the problem is cheers
  7. What speakers? Any subs? Other processing units? hi there, i'm running peavey rx'2 speakers at 4ohms 500contin, 1000w program, 2000w peak via alexis multi mix usb 8, music source is just my macbook i may add some subs later in the very same range but i'll be buying 2 other amps to run them,
  8. What speakers? Any subs? Other processing units?
  9. hi there i've been running pa amps for my home system, though i do find if i put home hifi speakers in them your never get super volume out of them, i run 2 x xls 2000's, through a alesis multimix 8 which have even mre gain then speakers are peavey hisys rx'2 at 4 ohms, the sound is purelwy a dream, compared to the kef reference and cyrus amps i had costing about 5 times as much i've been totally blown away at the quality and i'll never turn back to to normal hi-spec hif again, and the bonus is your be the man for all those loud partys, lol
  10. hi there.! i have just bought 2x xls 2000 amps , i absolutley love then compared to the numark dimensions i was running, i mainly use these at home and do events for freinds and the occasinal club, even let bands plugin through my alesis multimix, my question is al though i have perfect ear with mixers graphics to get ultimate sound, i am rather preplexed when it comes to the pureband crossover system, not something i really want to be mucking about with when i have a host of other equalizers to play with, so with this in mind can anyone tell if theres a standard setting for this system that just plays out the pure signal as it is ment to be without altering the sound in anyway shape or form, it may seem a silly question to ask but its thrown me as i'm not a sound engineer as such, when i turned on the 1st amp it was set 83hz please help this englishman under stand in plain english, lol cheers