Deromax

Members
  • Content count

    138
  • Joined

  • Last visited

Community Reputation

0 Neutral

1 Follower

About Deromax

  • Rank
    Power User
  • Birthday 07/12/1972

Contact Methods

  • Website URL
    http://
  • ICQ
    0

Profile Information

  • Gender
    Male
  • Location
    Lac-a-la-tortue, PQ, Canada
  • Interests
    Home theater, audio recording, loudspeakers design, old VWs, Mac computers, reel-to-reel audio recorders

Recent Profile Visitors

9,238 profile views
  1. Most, if not all, pro amps may be considered as two mono amps, so each channels are totally independant and can do different duties.
  2. Hello! We're once again full of strange language, irrelevant messages! Thanks for your work mods!
  3. You'd have better luck in a home theater forum, which this one is not!
  4. What this have to do with the Crown brand professionnal power amplifiers that are discussed here?
  5. The red LEDs are for clip or limiting, not thermal. I'm at loss as to what is causing your issues. The 2500 will put out up to 1200 watts per channel at 2 ohms, that is a lot of power for hifi speakers. Maybe the 15" are bottoming-out?
  6. IMHO, a 30 seconds note is not a transient but a very long sustained note! What indication do you get to conclude on a thermal issue? Do the fan spin at full blast? Have you checked at your power outlet for voltage sag with those songs playing?
  7. There is no such thing as positive delay, that would mean inventing something that hasn't happened yet. The best you can do is delaying whatever is in advance of the other. Typically, the picture will be late and you'll need to delay the sound to match.
  8. I never heard of a device outputing +30 dBu, that would be 25 volts rms. Most of them max-out around +23 dBu and most input can accomodate that. So clipping an input is more or less improbable. What can happen is clipping *inside* an upstream device, like a mixer. In this case, even if you lower its final output, the clipped waveform will still pass, even if it's lowered in amplitude.
  9. I have mixed feelings toward cascading a few AD and DA stages. On one side I think they should be minimized, for the principle. On the other hand, if the specs are great, this is more or less a non-issue. Take the XLS, they have a 103 dB SNR. This obviously point toward a 24 bits conversion, which is better than the 16 bits CD standard itself. You could then think that the noise of the amp is not very important in this case, since it's 7 dB lower than the CD that is feeding it. Hence the additionnal AD and DA is of no concern. My 0,02 !
  10. The processing needed to make the Drivecore system works needs to be done digitally. This is not merely a DSP function stuck on an analog amp to provide EQ and crossover. It's part of the design. And it's more or less irrelevant on a technical point of view. If this is an hifi philosophy thing, then you should be prepared to accept this as more and more amps will use some Class-D variant in the future. Equipment and appliances manufacturers are being put under pressure by regulation bodies to increase the efficiency of their products, and in this context, a big Class AB amp with linear power supply is out of the question, let alone Class A!
  11. A friendly suggestion for a little housekeeping on the forum! Lots of spam lately! Thanks!
  12. Appart from the off topic post about QSC... maybe you were clipping something in your mixer. Running it lower and having some more gain at the amp to compensate avoided this. The gain on the amp have little to do with the issue per se.
  13. First, amps have no ohms per se. They are rated to operate in some given ohms range speakers. Most pro amp will support 8, 4 or 2 ohms loads, but 2 ohms is very taxing for the amp. So, in your case, you could run one sub to channel 1 and the other sub to channel 2 somewhat safely, but watch for overheating if you need high output.
  14. Hello. You could try another set of speaker cable, then another set of speakers if you have some, to assess than it's not a problem outside of the amp. Then, use a voltmeter to check if the voltage is droping too low when the amp is used. However, the 8 ohms being an easy load and this amp being so efficient, I cannot see how the voltage could drop that much. If the issue continue with other equipment and the voltage stays OK, then I think the amp should be serviced.