• Content count

  • Joined

  • Last visited

Community Reputation

0 Neutral

About ectodude

  1. I am not sure why you can't download the .pdf file but I have posted it on USENDIT for you. You should be receiving an email from them with instructions on how to get to it. It will be available for 7 days. Hello David! Newbie here and was suffering the exact problem here (no bridge sw, and trying to make cables) and could ALSO not open the PDF file. HALP! PS... is this as simple as just jumping pins 1 and 3 on the input xlrs? Thanks in advance! Brian
  2. Hey, cool! Thanks Fishel! I guess I shoulda looked in THAT forum instead. So no switch needs to get flipped, (No switch TO flip!) bridge pins 1 and 3 on the input and run the 2 positives on the outut. Awesome. New Jersey is gonna be ROCKIN tonight! lol Thanks for the quick reply! PS... as a quick aside... is what I have an early version of the 402 or is it just not an option that was selected for mine? (both second hand units). You seem to be very knowledgable and I like to know all about stuff I own. I have read the revision history on the crown website on the CE series (also own a CE-1000 which *I* feel is a better amp... could be wrong there) but dont remember seeing the same history for the xls series. Took enough of Your time... Thanks! Brian
  3. Hey there, Newbie here... Going from home audio to commercial audio in my basement (yeah... 10 x 12 room with 18 madison subs and 15" pa cabs. FUN!). Anyways, I was wondering if I can run my xls402s (2 of them) in mono bridge mode for my subs if they do NOT have the "mono bridge mode" switch I see on the websites docs for hookup? Maybe these are older units (pre bridgeable?)??? I hooked them up as shown for mono bridge using the 2 + binding posts for output to the subs but they sound like they are bottoming at fairly low levels and I KNOW they have way more in them!!! HALP! Thanks for any input! Brian